ANALOG, ISDN AND DOV DIAL-IN ON A SINGLE CISCO PRI


Update July 2002

Our server is now running IOS 12.2 but the DoV config is still pretty much the same. About the only change is that the unit now has both PRI's connected to Telstra OnRAMP30 services to allow up to 60 simultaneous dial-in calls. 

(The AS5350 is also now accepting PPPoE connections on the Fast0/1 port to terminate DSL connections from some of our broadband customers. We have a SHDSL DSL Ethernet Bridge connected to the Fast0/1 port which then connects to our DSL VLAN and then goes out to our customer premises. The customers "dial in" to the AS5350 using PPPoE and they are connected pretty much as if they had dialed in. The PPPoE specific stuff is colored with blue text. So unless you have interest in PPPoE connections, you can ignore the blue parts of the config.)

as5350-1.gln#sh run
Building configuration...

Current configuration : 7485 bytes
!
! Last configuration change at 19:20:38 aes Thu Jul 18 2002
! NVRAM config last updated at 19:09:42 aes Thu Jul 18 2002
!
version 12.2
service timestamps debug datetime
service timestamps log uptime
service password-encryption
!
hostname as5350-1.gln
!
boot system flash c5350-is-mz.122-2.XB6.bin
boot system flash c5350-is-mz.122-2.XA5.bin
no boot startup-test
no logging buffered
aaa new-model
!
!
aaa authentication login STORE_LOCAL local
aaa authentication login RADIUS_USER group radius
aaa authentication login LINE_PASSWD line enable
aaa authentication login CONSOLE none
aaa authentication enable default enable
aaa authentication ppp default group radius
aaa authorization network default group radius 
aaa accounting update periodic 30
aaa accounting network default start-stop group radius
aaa session-id common
enable secret XXXXXX
!
username XXXX password XXXXXX
!
!
resource-pool enable
resource-pool call treatment resource busy
resource-pool call treatment profile busy
!
resource-pool group resource RESOURCE-ISDNPORTS
 range limit 60
!
resource-pool group resource RESOURCE-SPEMODEMS
 range port 1/0 1/59
!
resource-pool profile customer CUSTOMER-ALL-BUT-DOV
 limit base-size all
 limit overflow-size 0
 resource RESOURCE-ISDNPORTS digital  
 resource RESOURCE-SPEMODEMS speech  
 resource RESOURCE-ISDNPORTS V110  
 dnis group DNIS-ALL-BUT-DOV
!
resource-pool profile customer CUSTOMER-DOV
 limit base-size all
 limit overflow-size 0
 resource RESOURCE-ISDNPORTS speech  
 dnis group DNIS-DOV
clock timezone aes 10
spe country australia
!
spe log-size 30
!
spe call-record modem
!
!
!
!
!
ip subnet-zero
no ip source-route
ip cef
ip domain-name pipeline.com.au
ip name-server XXX.XXX.XXX.XXX
ip name-server XXX.XXX.XXX.XXX
!
multilink virtual-template 4
multilink bundle-name both
virtual-profile virtual-template 4
virtual-profile aaa
vpdn enable
!
vpdn-group 2
 description ** Define how to handle PPPoE connections
 accept-dialin
  protocol pppoe
  virtual-template 2
!
async-bootp time-server XXX.XXX.XXX.XXX
async-bootp dns-server XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
isdn switch-type primary-net5
!
!
!
!
!
!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
controller E1 3/0
 pri-group timeslots 1-31
 description ** Telstra OnRamp30 FNN A0352731600K1001
!
controller E1 3/1
 pri-group timeslots 1-31
 description ** Telstra OnRamp30 FNN A0352731600K1002
!
!
!
interface Loopback0
 no ip address
!
interface Loopback1
 description ** Create a /26 network advertisement for ASYNC/ISDN dialin pool
 ip address XXX.XXX.XXX.XXX.62 255.255.255.192
!
interface Loopback2
 description ** Create a /27 network advertisement for the PPPoE-Pool1
 ip address XXX.XXX.XXX.94 255.255.255.224
!
interface FastEthernet0/0
 description Pipeline Internet Geelong POP LAN
 ip address XXX.XXX.XXX.16 255.255.255.128
 no ip redirects
 ip ospf authentication-key XXXXXXXXXXXXX
 ip ospf priority 50
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description ** PIPELINE <-> NEXTEP GEELONG GATEWAY
 bandwidth 1500
 no ip address
 duplex auto
 speed auto
 pppoe enable
!
interface Serial0/0
 no ip address
 shutdown
 clockrate 2000000
!
interface Serial0/1
 no ip address
 shutdown
 clockrate 2000000
!
interface Serial3/0:15
 description ** Serial3/0:15
 no ip address
 encapsulation ppp
 ip tcp header-compression passive
 dialer rotary-group 2
 dialer-group 1
 isdn switch-type primary-net5
 isdn incoming-voice modem
 no fair-queue
 no cdp enable
!
interface Serial3/1:15
 description ** Serial3/1:15
 no ip address
 encapsulation ppp
 ip tcp header-compression passive
 dialer rotary-group 2
 dialer-group 1
 isdn switch-type primary-net5
 isdn incoming-voice modem
 no fair-queue
 no cdp enable
!
interface Virtual-Template2
 description *** PPPoE Template for Pool1
 mtu 1492
 ip unnumbered Loopback2
 no ip route-cache cef
 ip mroute-cache
 peer default ip address pool PPPoE-Pool1
 ppp max-bad-auth 3
 ppp authentication chap ms-chap
 ppp ipcp dns XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
!
interface Virtual-Template4
 description ** ASYNC/ISDN Template
 ip unnumbered Loopback1
 peer default ip address pool AS5350-1-POOL
 ppp max-bad-auth 3
 ppp authentication pap
 ppp ipcp dns XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
 ppp multilink
!
interface Group-Async0
 description ** Group-Async0
 ip unnumbered Loopback1
 dialer in-band
 dialer rotary-group 2
 dialer-group 1
 async mode dedicated
 no fair-queue
 group-range 1/00 1/59
!
interface Dialer2
 description ** Dialer2
 ip unnumbered Loopback1
 encapsulation ppp
 ip tcp header-compression passive
 no ip mroute-cache
 no keepalive
 dialer in-band
 dialer idle-timeout 0
 dialer-group 1
 peer default ip address pool AS5350-1-POOL
 no fair-queue
 no cdp enable
 ppp max-bad-auth 3
 ppp authentication pap
 ppp ipcp dns XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
 ppp multilink
!
router ospf XXXX
 router-id XXX.XXX.XXX.16
 log-adjacency-changes
 area 0 authentication
 redistribute connected subnets
 redistribute static subnets
 network XXX.XXX.XXX.0 0.0.0.127 area 0
!
ip local pool AS5350-1-POOL XXX.XXX.XXX.1 XXX.XXX.XXX.60
ip local pool PPPoE-Pool1 XXX.XXX.XXX.65 XXX.XXX.XXX.93
ip classless
ip route 0.0.0.0 0.0.0.0 XXX.XXX.XXX.1
no ip http server
ip ospf name-lookup
!
ip radius source-interface FastEthernet0/0
logging XXX.XXX.XXX.XXX.38
access-list 100 permit ip any any
!
dialer dnis group DNIS-ALL-BUT-DOV
 number 52731600
!
dialer dnis group DNIS-DOV
 number 52731601
dialer-list 1 protocol ip permit
no cdp advertise-v2
!
!
radius-server host XXX.XXX.XXX.6 auth-port 1645 acct-port 1646 non-standard
radius-server host XXX.XXX.XXX.3 auth-port 1645 acct-port 1646 non-standard
radius-server retransmit 3
radius-server key XXXXXXXXXXX
radius-server vsa send accounting
call rsvp-sync
!
voice-port 3/0:D
 compand-type a-law
!
voice-port 3/1:D
 compand-type a-law
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
line con 0
 location ** CONSOLE CABLE
 exec-timeout 0 0
 password XXXXXXXXXX
 logging synchronous
 login authentication LINE_PASSWD
line aux 0
 logging synchronous
line vty 0 4
 exec-timeout 180 0
 login authentication STORE_LOCAL
line 1/00 1/59
 no flush-at-activation
 no modem callout
 modem Dialin
 autocommand  ppp
 transport input all
 autoselect ppp
!
scheduler allocate 10000 400
facility-alarm detect controller E1 3/0
facility-alarm detect modem-board 1
facility-alarm detect controller E1 3/1
!
ntp clock-period 17180023
ntp source FastEthernet0/0
ntp update-calendar
ntp server XXX.XXX.XXX.38
end
    

BACK TO THE MAIN PAGE